Plugin darksky

protocol plugin

Im folgenden sind etwaige Anforderungen und unterstützte Hardware beschrieben. Danach folgt die Beschreibung, wie das Plugin darksky konfiguriert wird. Außerdem ist im folgenden beschrieben, wie das Plugin in den Item Definitionen genutzt werden kann. [1]

Beschreibung

Wetterdaten über darksky.net.

Anforderungen

  • Minimum SmartHomeNG Version: 1.4c

Konfiguration

Im folgenden ist beschrieben, wie das Plugin darksky konfiguriert wird. Außerdem ist im folgenden beschrieben, wie das Plugin in den Item Definitionen genutzt werden kann.

Parameter

Das Plugin verfügt über folgende Parameter, die in der Datei ../etc/plugin.yaml konfiguriert werden:

cycle

(optional) Zeit zwischen zwei Updateläufen. Default ist 300 Sekunden.

  • Datentyp: int
  • Standardwert: 300

key

Persönlicher API Key für darksky.net. Registrierung unter https://darksky.net/dev.

  • Datentyp: str

lang

Sprache der zurückgelieferten Daten. Mögliche Werte siehe https://darksky.net/dev/docs.

  • Datentyp: str
  • Standardwert: de

latitude

Latitude des Ortes, für den die Wetterdaten abgerufen werden sollen. Default: SmartHomeNG Settings

  • Datentyp: str

longitude

Longitude des Ortes, für den die Wetterdaten abgerufen werden sollen. Default: SmartHomeNG Settings.

  • Datentyp: str

units

Einheit der zurückgelieferten Daten. Mögliche Werte siehe https://darksky.net/dev/docs.

  • Datentyp: str
  • Standardwert: auto

Item Attribute

Das Plugin unterstützt folgende Item Attribute, die in den Dateien im Verzeichnis ../items verwendet werden:

ds_matchstring

Matchstring basierend auf der Response des „Forecast Request“ aus https://darksky.net/dev/docs (Example Request), bspw. „currently/temperature“. Ausnahmen: Im Fall von „alerts“ wird ein Item vom Typ „list“ benötigt, der Wert „alerts_string“ schreibt die Alerts-Liste in einen HTML String. Das Array in „flags/sources“ wird in ein „str“ Item gemerged.

  • Datentyp: str
[1]Diese Seite wurde aus den Metadaten des Plugins erzeugt. Für den Fall, dass diese Seite nicht alle benötigten Informationen enthält, bitte auf die englischsprachige README Datei des Plugins zugreifen.